github上的仓库里没有编译arm版本的docker-compose,需要自己编译,这里记录编译的办法。

我使用的系统是Debian buster,首先安装docker

1
curl -fsSL https://get.docker.com -o get-docker.sh

接下来安装docker-compose,

1
2
3
4
sudo apt install python python-pip python-dev python-setuptools libffi-dev
pip install pip -U
pip config set global.index-url https://pypi.tuna.tsinghua.edu.cn/simple
sudo pip install docker-compose

然后等待一万年。。。。。让pip自动帮你编译安装就可以用了。